سیسکو به‌روزرسانی‌های مورد نیاز محصولاتش را عرضه کرد « آموزش و انجمن تخصصی شبکه

یکشنبه 4 مهر 1395 ساعت 08:47
 سیسکو به‌روزرسانی‌های مورد نیاز محصولاتش را عرضه کرد

شرکت «سیسکو» به‌روزرسانی‌های نرم‌افزاری را برای...   وصله کردن چند آسیب‌پذیری مهم و سطح بالا که منجر به حمله منع سرویس در محصولات (Wireless LAN Controller (WLC این شرکت می‌شوند، ارائه کرده است. سیسکو درباره آسیب‌پذیری‌های شناسایی در محصولاتش عنوان کرده است که هفته بحرانی و پراسترسی را پشت سر گذاشته‌اند. اولین و مهم‌ترین رخنه‌ای که درجه بحرانی به آن اختصاص داده شده است، به کنترل ناصحیح ترافیک انتقال ابر متن (HTTP) مربوط است که با کمک آن هکر می‌تواند درخواستی را برای یک دستگاه ارسال کند و در ادامه شرایط سرریز بافر را به وجود آورد و در نهایت، حمله منع سرویس را پیاده‌سازی کند.

این رخنه که روی طیف گسترده‌ای از دستگاه‌های WLC سیسکو وجود دارد، با عنوان «Cisco Wireless LAN Controller HTTP Parsing Denial of Service Vulnerability » در تاریخ 20 آوریل در پایگاه اطلاع‌رسانی محصولات سیکسو به ثبت رسیده است. دستگاه‌های دارای نسخه‌های 7.2، 7.3، 7.4 و 7.5 تا (اMDا) 7.4.140.0, 7.5, 7.6 و 8.0 به این آسیب‌پذیری آلوده بوده‌اند. آسیب‌پذیری‌ دیگر شناسایی‌شده در WLC که با عنوان « Cisco Wireless LAN Controller Management Interface Denial of Service Vulnerability» در تاریخ 20 آوریل در پایگاه اطلاع‌رسانی محصولات سیکسو به ثبت رسیده است، به خطایی در خصوص واسط مدیریت دستگاه در وب بازمی‌گردد. رخنه واسط وب تنها در دستگاه‌هایی که از نسخه‌های 4.1 تا 7.4.12.0 و 7.5 و 7.6.100.0 نرم‌افزار AireOS این شرکت استفاده می‌کنند، قرار دارد. با استفاده از این آسیب‌پذیری، هکر می‌تواند کاربر را فریب دهد تا از آدرس‌های URL که توسط این واسط پشتیبانی نمی‌شود، بازدید کرده و دستگاه را مجبور به بارگذاری مجدد کند. این آسیب‌پذیری در نهایت باعث پیاده‌سازی یک حمله منع سرویس می‌شود.
آسیب‌پذیری «Bonjour» که با عنوان «Cisco Wireless LAN Controller Denial of Service Vulnerability» در تاریخ 20 آوریل در پایگاه اطلاع‌رسانی محصولات سیکسو به ثبت رسیده است، به مدیریت نادرست ترافیک ناشی از مدیریت کار (وظیفه) روی WLC بازمی‌گردد که دسترسی بدون مجوزی در اختیار هکر قرار می‌دهد. هکر با بهره‌برداری از این آسیب‌پذیری می‌تواند حمله Bonjour را پیاده‌سازی، دستــــگاه قربانـــی را مجدداً بارگـــذاری (reload) و همانند دیگر آسیب‌پذیــــری‌هــای شناسایی‌شده اقدام به پیاده‌سازی یک حمله منع سرویس روی دستگاه‌ آلوده کند.
دو آسیب‌پذیری شناسایی‌شده دیگر در نرم‌افزار تجهیزات انطباقی این شرکت، «ASA»، سرنام Adaptive Security Appliance، و «کتابخانه پروتکل انتقال فوری امن SRTP» قرار داشته‌اند. آسیب‌پذیری ASA که با عنوان « Cisco Adaptive Security Appliance Software DHCPv6 Relay Denial of Service Vulnerability» در تاریخ 20 آوریل در پایگاه اطلاع‌رسانی محصولات سیکسو به ثبت رسیده است، به دلیل اعتبارسنجی نادرست و ناکافی بسته‌های DHCP76 رخ می‌دهد. یک هکر با بهره‌برداری از این آسیب‌پذیری اقدام به ارسال بسته‌های DHCPv6 برای یک دستگاه آلوده می‌کند. نتیجه این کار پیاده‌سازی یک حمله منع سرویس می‌شود. این آسیب‌پذیری تنها کاربرانی را که از نسخه 9.4.1 این نرم‌افزار استفاده می‌کنند، تهدید می‌کند. آسیب‌پذیری مذکور فقط روی ترافیک IPV6 تأثیرگذار است.

larger-15-Cisco-Security-1A[1]
آسیب پذیری SRTP که با عنوان « Multiple Cisco Products libSRTP Denial of Service Vulnerability» در تاریخ 20 آوریل در پایگاه اطلاع‌رسانی محصولات سیکسو به ثبت رسیده است، در کتابخانه پروتکل انتقال فوری امن در زیرسیستم پردازش رمزنگاری که این کتابخانه از آن استفاده می‌کند، قرار دارد. مکانیزم استفاده‌شده در این سیستم آن‌گونه که باید توانایی بررسی و اعتبارسنجی تعدادی از بخش‌های این کتابخانه را ندارد و در نتیجه این بخش‌ها به‌راحتی در معرض دید هکر‌ها قرار دارند. بررسی سیسکو نشان می‌دهد نزدیک به 20 محصول مختلف این شرکت نسخه‌ای از این کتابخانه آسیب‌پذیر را به صورت ترکیبی در خود جای داده‌اند.

از جمله این موارد می‌توان به Webex Meetings Server، Jabber، ASA Software، IOS XE software و ده‌ها دستگاه‌ ارتباطی و صوتی که توسط این شرکت ساخته‌اند، اشاره کرد. جدول زیر محصولاتی را که به این آسیب‌پذیری آلوده شده‌اند، نشان می‌دهد. «libsSTRP» کتابخانه منبع‌بازی است که از روی SRTP پیاده‌سازی شده است. این کتابخانه منبع‌باز که در گیت‌هاب به نشانی https://github.com/cisco/libsrtp قرار دارد، یک آسیب‌پذیری را در کد‌های منبع خود جای داده بود. راندل جسوپ از گروه فایرفاکس، سال گذشته رخنه libsSTRP را شناسایی کرده بود. در پایان ذکر این نکته ضروری است که بیشتر آسیب‌پذیری‌هــا را خود کارمنـــدان شــرکت سیســـکو شناسایی کرده‌اند و در نتیجه هیچ‌گونه نشانه‌ای از اینکه از این آسیب‌پذیری‌ها با اهداف مخــرب سوءاستفاده شـــده باشد، وجود ندارد.smile icon

برای دانلود صدها eBook ، نرم افزار ، آموزش و کتاب دیگر کلیک کنید.



دانلود AppDev ، دانلود AskVideo ، دانلود Career Academy ، دانلود CBT Nuggets ، دانلود AsileFX ، دانلود CG Cookie ، دانلود cmiVFX ، دانلود Coursera ، دانلود Cisco Press ، دانلود Drupalize me ، دانلود Digital Tutors ، دانلود EC-Council ، دانلود Educator ، دانلود Escape Studios ، دانلود Eat3D ، دانلود fxphd ، دانلود Gumroad ، دانلود Gnomon Workshop ، دانلود Groove3 ، دانلود INE ، دانلود Infinite Skills ، دانلود K.Alliance ، دانلود KelbyOne ، دانلود LinuxCBT ، دانلود LiveLessons ، دانلود LearnVisualStudio.NET ، دانلود Lynda.com ، دانلود MasterPhotoWorkshop ، دانلود Massive Synth ، دانلود 3DMotive ، دانلود MacProVideo ، دانلود Class On Demand ، دانلود PacktPub ، دانلود PhotoshopCAFE ، دانلود PhLearn ، دانلود PluralSight ، دانلود Peachpit ، دانلود Ripple Training ، دانلود Sonic Academy ، دانلود Schoolism ، دانلود SSD Tutorials ، دانلود Skillfeed ، دانلود Treehouse ، دانلود Tekpub ، دانلود TutsPlus ، دانلود GameTutor ، دانلود TrainSignal ، دانلود Total Training ، دانلود Think Vitamin ، دانلود Udemy ، دانلود Video2Brain ، دانلود VTC ، دانلود Winstructor ، دانلود ZBrushWorkshops ، دانلود SecurityTube ، دانلود CreativeLive ، دانلود Linux Academy ، دانلود OS Training ، دانلود Cloud Academy ، دانلود Cybrary ، دانلود CodeSchool ، دانلود RouteHub ، دانلود ITProTV ، دانلود GoGo Training ، دانلود LearnNowOnline ، دانلود SVS ، دانلود Uartsy ، دانلود VideoMakers

برچسب‌ها: AireOS، Bonjour، Cisco ASA، IOS XE، libsSTRP، SRTP
نظرات (0)
امکان ثبت نظر جدید برای این مطلب وجود ندارد.